Site Web Clé En Main

Partenaire de votre Communication Internet

 

Dois-je changer la version de Joomla ! de mon site ?

 

Un exemple : plusieurs de mes clients ont reçu ce type de message de Google :

Mise à jour de Joomla disponible

La dernière exploration de votre site nous a permis de constater que vous utilisiez Joomla 1.5. Voici quelques-unes des URL trouvées :

  ----Une page du site ------

Nous vous recommandons d'installer la dernière version de ce logiciel. Les versions plus anciennes ou dépourvues de correctifs sont plus vulnérables aux attaques des pirates informatiques et aux logiciels malveillants susceptibles de gêner vos utilisateurs.

 

Pas de panique, prenez le temps d'étudier la situation avant de prendre une décision

 

La version J1.5 est la version la plus courante pour les sites créés avant le printemps 2012, il n'y a plus d'évolution de J1.5 (du noyau, du moteur du site), depuis septembre 2012

Le catalogue des extensions compatible j1.5 est vaste et continue à être entretenu, mais de moins en moins.

  • Un site développé en Joomla 1.5 fonctionne et continuera à fonctionner encore quelque temps.
  • Il peut y avoir des problèmes avec certaines fonctionnalités sur certains navigateurs et il y en aura surement de plus en plus.
  • Ces sites s'affichent mal sur les Smartphone
    • Rien ne presse mais la migration devra se faire tot ou tard.
  • Il n'est pas nécessaire ou urgent d'entreprendre une migration immédiate, mais il faudra surement s'y résoudre dans les mois à venir. Il est recommendé de faire appel à un professionnel, afin de s'assurer de la conservation de toutes les fonctions et du contenu du site actuel.
  • Les versions J2.5 et J3.x permettent en plus des possibilités de mise en page et de présentation bien plus riches,
    • une meilleure protection contre les attaques,
    • une gestion plus fine des accès utilisateurs,
    • un meilleur référencement,
    • un catalogue plus vaste d'extentions pour de nouvelles fonctions.

Donc je pense que la migration de J1.5 vers une version actuelle est inéluctable. Mais ce n'est pas un raison pour le faire comme si c'était une urgence. (voir Quelle version Joomla ?)